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GETTING STARTED WITH ConceptDraw PRO 

Thank you for your interest in ConceptDraw® PRO v9! Let’s begin by installing the program on your system. 

To install the product, and activate your trial license:  

1. Navigate your web browser to www.ConceptDraw.com and click Join Us. 

 

Figure 1: Creating a new account on ConceptDraw.com 

2. Fill in the form with your information, and then click Submit. 

3. Check your email for the message from support@ConceptDraw.com that contains your confirmation link. (Spam 
filters may catch this message. If you don’t see the email within a few minutes, check your “Junk” or “Spam” 
folders.)  

4. Follow the link to confirm your account, and then click Proceed to installation. 

5. Click Download All ConceptDraw Products or Solutions. 

 

Figure 2: Downloading ConceptDraw Office Trial 

6. Once the download is complete, run the installation file. 

http://www.conceptdraw.com/
mailto:support@conceptdraw.com
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7. Follow all on-screen instructions to complete the installation. 

8. Once the program is installed and launched, you will be prompted to enter your ConceptDraw account 
information. Do so. 

9. Wait briefly for your account to be synchronized.  

10. Congratulations! Your FREE 21-day trial of ConceptDraw PRO has begun. 

TEMPLATE GALLERY 

ConceptDraw PRO is so versatile that knowing where to even begin can be difficult, which is precisely why it includes an 
extensive Template Gallery. From the File menu in the upper-left corner of the window, select Template Gallery.  

 

Figure 3: Template Gallery 

Choose a category in the left pane of the window, and the center pane will display the various templates available. The 
Template Gallery contains numerous examples to help you get started such as flow charts, org charts, process maps, 
swim lanes diagrams, IT and network diagrams, building plans, software UI prototype templates, and many more. 

ADDING SHAPES 

The easiest way to add shapes to your drawing is from a 
Library. Click Libraries on the ribbon to display the 
Library pane, which contains all the libraries currently 
active in your drawing. You can add libraries by clicking 
the Categories button and selecting from the list 
displayed in the upper box of the pane. You can also 
search categories by clicking the Search icon. Search 
results are compiled into a new active library. Select an 
active library to view the shapes it contains and then 
drag and drop shapes into your drawing. Click the X 
next to an active library’s name to remove it from the 
drawing.

 

Figure 4: Library Pane 



 

 

On your drawing, you can rearrange shapes by dragging-and-dropping, as well as cut, copy, and paste with standard 
keyboard shortcuts. You can also use Duplicate (from the Edit menu, or Cmd+D) to create one exact duplicate of the 
selected object. 

The Clone Tool is the easiest way to place multiple copies of a shape. Select a shape, and then activate Clone tool. With 
each click, you will place a copy of the selection. Press Esc on your keyboard to deactivate Clone Tool when you’re done. 

 

 

Figure 5: Clone Tool 

CONNECTING OBJECTS 

You have two options for drawing connections between objects: Direct Connectors, and Smart Connectors. 

Direct Connectors are straight lines from the point of origin to the point of contact. Select Direct Connector, click the 
point you wish to originate the connector from, and then drag your mouse to the desired end point and release the 
mouse button.

 

 

Figure 6: Direct Connector 
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Smart Connectors are drawn very similarly to Direct Connectors via click-and-drag. However, they will automatically 
route around objects already placed in your drawing. 

 

 

Figure 7: Smart Connector 

WORKING WITH YOUR DRAWING 

To change the style of a shape in your drawing, view the 
Inspectors (by clicking the button on the ribbon). 
Expand the Fill palette to view a variety of colors, 
gradients and textures. Also on this palette are style 
options for Line, Shadow and Text. 

 

Figure 8: Shape Style Inspector 

You have even more options for working with shapes right on the toolbar. Rotate and Flip transform a selection 
geometrically. Align is used to align multiple shapes along a single axis. Distribute spaces shapes evenly on the page. 
Front and Back place shapes on different layers of the drawing. Identical conforms the dimensions of the secondary 
selection (blue highlight) to those of the primary selection (green highlight). Click the buttons to select from the 
different parameters for the chosen operation. 

 

Figure 9: Shape Tools on the toolbar 
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You can Group shapes to make multiple shapes move as a single unit, yet retain their individual properties, by pressing 
Cmd+G, or selecting Group from the Shape menu. Use Cmd+U to ungroup. Also on the Shape menu is the Operations 
submenu. This contains Join, which makes multiple shapes into a single shape, and Separate, which reverses that 
operation. 

You can add a hyperlink to an object by selecting it, and 
then opening the Inspectors. Expand the Behavior 
palette and select the Hyperlink icon. On that tab, you 
can select the type and destination of your hyperlink. 

 

Figure 10: Hyperlink Inspector 

GRID AND RULERS 

You can fine tune the alignment of your drawing by configuring Grid & Rulers and Snap & Glue on the Tools menu. 

SMART OBJECTS 

Many of ConceptDraw PRO’s libraries contain Smart Objects, identified by a blue tile in the library pane. Smart Objects 
are shapes with unique properties that can be edited by clicking the Smart Object icon that appears when they are 
selected in a drawing. 

 

Figure 11: Smart Object icon 

RAPID DRAW 

Rapid Draw mode is the fastest and easiest way to create a flowchart in ConceptDraw PRO. Select a shape in your 
drawing, and then engage Rapid Draw from the Shape menu. Hover your mouse over a shape in your drawing, and then 
click one of the small blue arrows that appear to draw a Smart Connector and Duplicate of the selection in the chosen 
direction.  



 

Page | 8 Getting Started with ConceptDraw PRO ©CS Odessa, August 2011 

 

Figure 12: quick flowcharting with Rapid Draw and Smart Objects 

Using Rapid Draw and a Smart Object such as Flowchart Shapes (from the Basic Diagramming>Basic Flowchart library), 
you can easily create complex flowcharts in practically no time. 

MULTI-PAGE DRAWINGS 

To add more pages to your drawing, select New Page from the Insert menu. The small left and right arrows in the 
bottom-left corner of the window scroll through the pages of your drawing. Click the Pages icon next to the arrows to 
open the Page Navigator tray.  

 

Figure 13: Pages Navigator tray 

CUSTOM LIBRARIES 

The File>Library menu offers you several options for creating custom libraries, such as creating a new blank library into 
which you can drag-and-drop shapes from your drawing, or saving the current library as a differently named file. 

IMPORTING/EXPORTING 

Also from the File menu, you can view all of ConceptDraw PRO’s import and export capabilities. Most notably, 
ConceptDraw PRO can import from and export to Microsoft® Visio’s® XML file format. You can also export to MS 
PowerPoint® files and a variety of other popular graphics file formats. 

PRESENTING YOUR DRAWING 

From the View menu, click Start Presentation to view a full-screen slideshow of your drawing. Each page will be its own 
slide. Click the mouse to advance slides. If you prefer to export to MS PowerPoint for presenting, the same concept 
applies: each page will become its own slide. 
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PRINTING YOUR DRAWING 

From the File menu, select Print to open the Print Preview. From this view, you can configure the various print options 
to ensure your drawing looks as great on paper as it does on the screen. Click Print to send your drawing to the printer, 
or Cancel to return to your drawing. 

SOLUTION PARK 

ConceptDraw Solution Park is an ever-growing collection of business-specific solutions and product add-ons that are 
available to add continued value after the initial purchase of a ConceptDraw product. For more information, visit 
http://www.conceptdraw.com/solutions.php. 

NO-CHARGE SUPPORT 

CS Odessa offers no-charge support for all licensed and trial users of ConceptDraw Products.  ConceptDraw Maintenance 
Assurance P1 is also available to stay current with major updates to ConceptDraw Products.  

CROSS-PLATFORM LICENSING 

CS Odessa is one of the only companies in the world that offers a cross-platform license.  So, if you want to install your 
product on a Mac OS machine and a Windows machine for your use, you can do so with our license. Most companies 
require that you purchase a separate license for each platform. 

OS X LION 

All ConceptDraw applications are compatible with Mac OS X Lion.  

MULTI-DISPLAY SUPPORT 

ConceptDraw PRO v9 supports working across multiple computer screens.  This allows you to work on one screen and 
present on another. 

MULTI-LANGUAGE SPELLCHECK 

ConceptDraw PRO offers Spell Check in a variety of different languages. 

ABOUT CS ODESSA 
Founded in 1993, Computer Systems Odessa supplies cross-platform productivity tools and graphics technologies to 
professional and corporate users around the world. From their headquarters in Odessa, Ukraine, and offices in San Jose, 
CA, and Boston, MA, CS Odessa sells internationally in over 150 countries, both directly and through resellers. The 
ConceptDraw Productivity Line has won numerous awards, and is used by hundreds of thousands all over the world. For 
more information, visit http://www.conceptdraw.com/. 

Technical Support/Sales Phone Numbers 

US/Canada/Mexico:  

Technical Support (Toll Free): +1 (877) 441-1150 x4 amersupport@csodessa.com 

Sales (Toll Free):   +1 (877) 441-1150 x3  amersales@csodessa.com 

Europe:  

+38 0487601963 support@conceptdraw.com sales@conceptdraw.com 

http://www.conceptdraw.com/solutions.php
http://www.conceptdraw.com/
mailto:amersupport@csodessa.com
mailto:amersales@csodessa.com
mailto:support@conceptdraw.com
mailto:sales@conceptdraw.com
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FREQUENTLY ASKED QUESTIONS 

What is the difference between Technical Support and Maintenance Assurance P1? 

Technical support is a no charge item provided to our customers and individuals trialing or products. Our Tech Support 

team is there to help you with installing, product activation, and product issues.  Technical support is available by 

submitting a ticket via our web site, and by phone and email. Minor product upgrades are at no additional cost. 

When purchased at the same time of you ConceptDraw Product purchase, Maintenance Assurance P1 provides you the 

next major release of your product at no additional cost.  When the next major upgrade of the product becomes 

available you will be notified of its availability for download and installation. 

Why is ConceptDraw Solution Browser part of the product I purchased? 

When you activate a purchased license for your product, that authorization is stored in the cloud, and then synchronized 

with your desktop product(s) using ConceptDraw Solution Browser.  We do this so if the unthinkable occurs and you 

have a catastrophic event with your computer such as a hard disk failure, you can log into your account on 

ConceptDraw.com and retrieve your license, saving you time and headaches. 

The ConceptDraw Solution Browser also manages the versioning of all of your products, and give you access to all of the 

additional business solutions found in the ConceptDraw Solution Park. 

I am with a large organization; do you support other methods of installation besides the one I experienced from my 

trial? 

We have additional methods of delivering product to the users in your organization.  Please contact our sales or support 

team for details. 

Do you have pricing for academia and nonprofits? 

Yes, we have aggressive pricing for students, educators and employees of certified nonprofit organizations. Contact our 

sales team for pricing details. 
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KEYBOARD SHORTCUTS 

Following is an abbreviated list of the most commonly used keyboard shortcuts. See the in-program Help file for the 

comprehensive list. 

Keystroke Operation 
Cmd + N Create a New Document 
Cmd + Opt + N Create a new document from template 
Cmd + O Open a Document 
Cmd + S Save the active document 
Cmd + Shift + S Save the active document under a new filename 
Cmd + P Print the active map 
Cmd + Shift + G Set Grid properties for the active document 
Cmd + Shift + U Set Snap & Glue options for the active document 
Cmd + A Select all the shapes on page 
Cmd + Z Undo the last operation 
Cmd + X Cut the selection to the Clipboard 
Cmd + C Copy the selection to the Clipboard 
Cmd + V Paste the content from the Clipboard 
Cmd + Opt + P Start Presentation 
Cmd + Shift + N Create a new library 
Cmd + Shift + O Open a library 
Ctrl + 1 Select tool 
Ctrl + 2 Text tool 
Ctrl + 3 Line tool 
Ctrl + 4 Sector tool 
Ctrl + 5 Arc tool 
Ctrl + 6 Spline tool 
Ctrl + 7 Rectangle tool 
Ctrl + 8 Ellipse tool 
Ctrl + 9 Connector tool 
Ctrl + 0 Eye Dropper tool 

 


